Cart

Your cart is empty

Setting

Language

Currency :

FREE SHIPPING for all orders over $40

-20%

TP-Link TD-W8961N 300Mbps Wireless N ADSL2+ Modem Router

$21.44 $26.80
Save 20%
  • Free shipping over $40
  • 7-day money back guarantee
  • Online live support anytime
SKU: ELEC-F12380
Category: Network Device

Product Specifications

  • ADSL 2/2+ Modem, Wireless N Access Point and 4-Port Router, in a single device
  • Wireless N speed up to 300Mbps makes it ideal for heavy bandwidth consuming or interruption sensitive applications like online gaming, Internet calls and even HD video streaming
  • Easy Setup Assistant with multi-language support provides quick & hassle-free installation
  • Easy one-touch wireless security encryption with the”WPS” button and Easy Wi-Fi On/Off button
  • HARDWARE FEATURES
  • Interface: 4 10/100Mbps RJ45 Ports
  • 1 RJ11 Port
  • Button 1 Power On/Off Switch
  • 1 WPS Button
  • 1 Wi-Fi On/Off Button
  • External Power Supply 9VDC/0.85A
  • IEEE Standards IEEE 802.3, 802.3u
  • ADSL Standards Full-rate ANSI T1.413 Issue 2,
  • ITU-T G.992.1(G.DMT),
  • ITU-T G.992.2(G.Lite)
  • ITU-T G.994.1 (G.hs),
  • ITU-T G.995.1
  • ADSL2 Standards ITU-T G.992.3 (G.dmt.bis),
  • ITU-T G.992.4 (G.lite.bis)
  • ADSL2+ Standards ITU-T G.992.5
  • Dimensions ( W x D x H ) 7 * 5.1 * 1.4 in. (195 * 130 * 35 mm )
  • Antenna Type Omni directional, Fixed
  • Antenna Gain 2x5dBi
  • WIRELESS FEATURES
  • Wireless Standards IEEE 802.11n, 802.11g, 802.11b
  • Frequency 400-2.4835GHz
  • Transmit Power <20dBm(EIRP)
  • Wireless Security Support 64/128 bit WEP, WPA-PSK/WPA2-PSK,
  • Wireless MAC Filtering
  • SOFTWARE FEATURES
  • Quality of Service QoS Remarking based on IPP/ToS, DSCP and 802.1p
  • Security NAT Firewall,
  • SPI Firewall,
  • MAC / IP / Packet / Application / URL Filtering,
  • Denial of Service(DoS),
  • SYN Flooding,
  • Ping of Death
  • Management Web Based Configuration(HTTP),
  • Remote management,
  • Telnet management,
  • Command Line Interface,
  • SSL for TR-069,
  • SNMP v1/2c,
  • SNMP over EOC,
  • Web Based Firmware Upgrade,
  • CWMP(TR-069),
  • Diagnostic Tools
  • Port Forwarding Virtual Server, DMZ, ACL(Access Control List)
  • VPN Pass-Through PPTP, L2TP, IPSec Pass-through
  • ATM/PPP Protocols ATM Forum UNI3.1/4.0,
  • PPP over ATM (RFC 2364),
  • PPP over Ethernet (RFC2516),
  • IPoA (RFC1577/2225),
  • PVC – Up to 8 PVCs
  • Advanced Features Traffic Shaping(ATM QoS) UBR, CBR, VBR-rt, VBR-nrt;
  • Dynamic Host Configuration Protocol (DHCP), DHCP relay;
  • Network Address Translation (NAT);
  • PVC/Ethernet Port Mapping
  • VLAN, 802.1P,
  • Static Routing, RIP v1/v2 (optional);
  • DNS Relay, DDNS,
  • IGMP snooping V1/2
  • IGMP Multicast,
  • UPnP
  • OTHERS
  • Certification CE, FCC, RoHS
  • Package Contents TD-W8961N
  • External Splitter
  • RJ-11 Telephone Cable
  • RJ-45 Ethernet Cable
  • Quick Installation Guide
  • Power Adapter
  • System Requirements Microsoft Windows 98SE, NT, 2000, XP, Vista Windows 7 or Windows 8, MAC OS, NetWare, UNIX or Linux.
  • Environment Operating Temperature: 0~40 (32~104)
  • Storage Temperature: -40~70 (-40~158)
  • Operating Humidity: 10%~90% non-condensing
  • Storage Humidity: 5%~90% non-condensing

Browse more Network Devices at EasyPC.

We offer fast and reliable shipping worldwide. All orders are carefully packaged and shipped within 1–3 business days after payment confirmation.

  • Fast shipping within 1-3 business days
  • Free shipping on orders over $40
  • 30 days money back guarantee
  • 24/7 online customer support
  • Secure packaging & safe delivery

Standard shipping, expedited shipping and express delivery options are available at checkout. Delivery time depends on your destination country and local logistics.

Reviews

There are no reviews yet.

Be the first to review “TP-Link TD-W8961N 300Mbps Wireless N ADSL2+ Modem Router”

Your email address will not be published. Required fields are marked *

You might also like

Add Related products to weekly line up